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1.  MAINE 3A software overview

1.1. Introduction
MAINE 3A is a simulation software product for predicting the acoustic properties of layered structures 
containing sound absorbing materials. Featuring a user-friendly graphical interface, MAINE 3A is a 
highly efficient tool for quickly optimising the sound absorption or insulation properties of multilayer 
materials.

MAINE 3A models the properties of individual layers (presumed to have infinite lateral dimensions) 
using a transfer matrix for high performance calculation times [4]. Available media include plates, 
visco-elastic solids, fluids, porous materials with deformable / non-deformable skeletons, thin resistive 
layers  and  perforated  plates.  The  process  involves  the  application  of  plane  wave  or  diffuse  field 
excitation. Results are presented in narrow bands or octave bands.

MAINE 3A was written by researchers from the Laboratoire d’Acoustique (Acoustics Laboratory) at 
the  Université  du  Maine  (LAUM  -  UMR  CNRS  6613)  an  institution  that  enjoys  a  worldwide 
reputation for its  work on modelling  porous sound absorbing materials.  (cf.  Scientific  references). 
Exploitation of the MAINE 3A code is  governed by a "CNRS-Université  du Maine" licence.  The 
software  source  code  has  been  deposited  at  the  Agence  de  Protection  des  Programmes  (French 
programme protection agency).

MAINE 3A is a trademark registered at INPI.

1.2. Features
MAINE 3A software allows the computation of:

• impedance, reflection coefficient, absorption coefficient
• transfer impedance
• transmission loss, 
• Rw, DLr, αW and DLα indicators

of a multilayer  material  placed between two fluid propagation media or on a rigid wall.  Acoustic 
excitation can be either diffuse field or plane wave of given incidence. Output is function of frequency 
or incidence angle.

The multilayer material is represented as a stack of propagation media of infinite lateral dimensions, 
modelled analytically (no mesh) by transfer matrices. Five types of propagation media are available :

• Viscoelastic,

• Gas

• Porous: dual-phase medium with open porosity, with rigid or viscoelastic skeleton

• Resistive screen

• Perforated screen



Porous materials are described by several models [1 to 3, 7 to 14] :

• Empirical model by Delany and Bazley
• Equivalent fluid model by Johnson-Champoux-Allard using 5 parameters: porosity, resistivity, 

tortuosity, viscous and thermal characteristic lengths,
• Equivalent fluid model by Limp: same equivalent fluid model as above, taking into account the 

density of the porous material. It uses six parameters : porosity, resistivity, tortuosity, viscous 
and thermal characteristic lengths, density

• Physical poroelastic model by Biot-Allard: the visco-thermal couplings description is the same 
as equivalent fluid models above, now taking into account the frame deformation and inter-
phase elastic coupling. It uses nine parameters : porosity,  resistivity,  tortuosity,  viscous and 
thermal characteristic lengths, density, Young modulus, loss factor, Poisson coefficient.

A simplified physical model is also available. It is particularly adapted for fibrous media. Tortuosity is 
set to 1, and the characteristic lengths are calculated from the porosity and resistivity values.

It is also possible to provide a frequency-dependant Young modulus for the solid phase in the cases of 
Biot model poroelastic layer and solid viscoelastic layer.

1.3. Demo version

A demonstration version is available to explore the capabilities of the MAINE 3A software featuring 
pre-calculated validation cases. This version features full graphics interface functionalities but no solv-
er, therefore it cannot perform computations

Demonstration configurations can be accessed via the "File / Demos" menu. The corresponding results 
can be consulted via the "Graph" menu. For some values it is possible to superimpose an experimental 
results curve using the "File / Reference" menu in the graphics window. 

All of the Graphical User Interface features can be browsed and tested, but the results cannot be modi-
fied.

2.Using the graphical user interface

2.1. Introduction: calculation steps
MAINE 3A software features a graphics interface which greatly simplifies the calculation process.



Overview of the graphical user interface: menus and buttons

Calculations can be performed by selecting individual menus (or icons from the taskbar) from left to 
right one after the other:

File
Open an existing or new multilayer medium model, save models, export computing outputs, 
start demos.

Add
Add a new fluid, porous or solid layer,  a resistive screen or a perforated screen. Select the 
created layer using the left mouse button to access the selected layer’s physical characteristics 
(provided manually or imported from a database). 
 

Parameters
Select angular or frequency dependence for plane waves or a frequency range for diffuse field 
excitation.  Select global indicators computation and the application of spatial  windowing if 
desired. Select the problem type, transmission or absorption on a rigid wall by clicking on the 
lower layer and changing its type.

Launch
Launch the solver (or click the lower right button in the main screen) 

Graph
Graphical display of the results, compare to a reference curve, save the results in a file. 

Tools
Access special tools such as precomputation of spatial windowing coefficients, compression of 
fibrous materials, import, edit or export a database, language selection.

Help
Classical help menu.

2.2. Managing models: the "File" menu
A model features all the input data of a problem, namely:

• the multilayer definition including the characteristics of each model,
• the type of excitation,
• the computation options (frequency range, spatial windowing, global indicators, etc.).

Information can be stored in a "model" file with the ".mod" extension. The toolbar features direct  
buttons for opening, saving and creating new models. Key combination shortcuts can also be used.

Command Effect

Ctrl + n New model

Ctrl + o Open

Ctrl + s Save



Ctrl + q Quit

F1 Help

Model management shortcuts

The "File" menu

The  "Demos"  menu  can  be  used  to  load  a  demonstration  model  featuring  precomputed  sample 
calculations (see Demonstration version). Demonstration models must be saved with a different name 
so that they can be recalculated.

The  "Export"  menu  allows  the  saving  of  the  multilayer  configuration,  input  data  used  for  the 
computation, and the obtained results (a computation therefore must have been performed) into a .txt 
file. See also the key combination shortcuts.

2.3. Creating a layer: the "Add" menu
A layer is defined by its type:

• Fluid layer, 
• Porous layer, 
• Solid layer, 
• Porous resistive screen, 
• Perforated screen. 

To create a new layer, select the type of layer in the "Add" menu or the corresponding icon in the  
toolbar. The layer will be added on top of the existing layers



The "Add" menu

Please note that:

• The thickness of the layer (if available) appears in the status bar while the mouse pointer is over 
a layer button.

• The surface mass of the multilayer is computed automatically whenever the required data is 
available (lower left corner frame).

2.4. Deleting, copying, pasting a layer: context menu
A layer can be cut, copied or pasted by right-clicking on its button.

To copy or suppress a layer, select it using the mouse right button and select the desired option in the 
contextual menu : cut, copy, paste above.

To paste a previously cut or copied layer above another layer, select the remaining layer by right-
clicking it and select the "paste above" action.

Right-clicking on a layer



2.5. Input a layer’s characteristics: left click

To input layer’s characteristics, simply select the desired layer using the left mouse button. A pop-up 
window will display the different parameters input fields. The same method applies to the initial "In-
cident medium" and "Transmission medium / Rigid wall " layers.
Notes : 

• According to the selected model, only the characteristics available for that model are active. 
Values are input manually.

• To move from one field to the other, the keyboard shortcut is the "Tab" key.

Some type of layers can be modelled using a variety of models. The desired model must be selected 
before inputting the parameters of the layer. 

 

Model selection

Available layer types are described in the next section..

2.5.1. Porous layer

Four models are available:
• Empirical model by Delany and Bazley
• Equivalent fluid model by Johnson-Champoux-Allard using 5 parameters: porosity, resistivity, 

tortuosity, viscous and thermal characteristic lengths,
• Equivalent fluid model by Limp: same equivalent fluid model as above, taking into account the 

density of the porous material. It uses six parameters : porosity, resistivity, tortuosity, viscous 
and thermal characteristic lengths, density

• Physical poroelastic model by Biot-Allard: the visco-thermal couplings description is the same 
as equivalent fluid models above, now taking into account the frame deformation and inter-
phase elastic coupling. It uses nine parameters : porosity,  resistivity,  tortuosity,  viscous and 
thermal characteristic lengths, density, Young modulus, loss factor, Poisson coefficient.

Notes: 

The default  physical  characteristics  (temperature  and pressure)  of the fluid phase are those of the 
incident medium (top layer).



Graphical comparison of the three physical models: absorption coefficient of a porous material layer  
resting against a rigid wall.

Porous layer characteristics



In the case of physical models, the frame (solid phase) can be either infinitely rigid (equivalent fluid 
model) or elastic (Biot-Allard model). In the latter case, it is possible to input a frequency depend 
Young modulus.  Check the box to activate the elastic frame parameters,  i.e.  Young modulus,  loss 
factor, volumic mass and Poisson ratio.

The  "simplified  physical  model"  option  allows  for  an  automatic  computation  of  the  viscous  and 
thermal  characteristic  lengths based on the values of airflow resistivity and porosity tortuosity,  by 
assuming a tortuosity value of 1. This model is particularly adequate for porous materials.

Note: 
Checking the "Simplified physical model" option from an existing set of parameters causes the 
modification of some of the parameters values. Unchecking the option does not restore the initial 
values of the parameters.

2.5.2. Solid layer

The model is that of an isotropic elastic material. It is possible to input a frequency dependant Young 
modulus file.

Solid layer characteristics

2.5.3. Fluid layer

The model is that of a viscothermic fluid. The temperature and pressure can be accessed through the 
graphical user interface. The default characteristics are those of the air at 20°C and 101325 Pa.



Fluid layer characteristics

2.5.4. Porous resistive screen

This model is suited for porous resistive screens (thin layers with high resistivity).

Porous resistive screen characteristics
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Comparing experimental measurements to simulations: absorption of an air layer behind a resistive  
screen (____  : impedance tube measurements ;  ----: normal incidence plane wave simulation)

2.5.5. Perforated screen

The perforated plate model interface window is as shown in the next figure.



Perforated plate characteristics

Comparing experimental measurements to simulations: absorption of an air layer behind a resistive  
screen (red: impedance tube measurements ;  black : diffuse field absorption simulation)



2.5.6. Top layer: incident fluid layer

The  at  rest  temperature  and  pressure  of  the  propagation  medium  can  be  changed.  The  default 
characteristics are those of air at 20°C and 101325 Pa. The characteristics of the top layer are used for 
all the fluid phases of all the porous materials layers.

Top layer characteristics

2.5.7. Bottom layer

Two options are available for the bottom layer: transmission medium or rigid impervious wall. This 
choice will decide which type of problem is processed : transmission or absorption. In the case of a 
transmission medium, the default temperature and pressure are those of the top layer

Characteristics of the bottom layer

2.5.8. Using the materials database

The characteristics of the layers can also be accessed via a materials database (file extension ".db")

• To create a database, click the "Create database" button.
• To select a database, click on the "Database" button.
• To read the data in a database :

• Click on the "Read a material" button, a list of materials compatible with the type of 
layer is displayed.

• Double click on the desired material to select it.
• To save a material into a database:

• Fill in the material’s name.
• Click on the "Save material" button. The material will append after the materials already 

stored in the database. A warning message will display if you are about to overwrite an 
existing material of the same name within the current database.

MAINE 3A features two default  databases:  standard.db which contains a set  of usual materials  of 
known properties, and demos.db which contains the materials used in the demonstration models. It is 
possible to modify a database by editing it.



Some special tools allow for easier management of the databases (refer to the Database section of the 
tools section).

2.6. Frequency dependant Young’s modulus
The Young modulus of solid layers and of porous materials’ frame (Biot model), can very frequency 
dependant. It is possible to input a frequency dependence for this parameter by checking the box next 

to the   icon. The user is  then prompted to input a filename.  The file  must  conform to the 
following rules:

• The 3 first lines are ignored. They can be used to comment the file,
• The first column is the ascending frequency,
• The second column is the Young modulus,
• The third column is the loss factor.

Furthermore, during calculations :

• If  needed,  the  values  of  the  Young  modulus  are  interpolated  for  unavailable  intermediate 
frequencies,

• The value at the lowest available frequency is used for all frequencies below,
• The value at the highest available frequency is used for all frequencies above. 

Example of a file: 

# Used for comments
#      Green material
# freq  E  eta
1000    5e5  0.1
5000   5e7 0.001

2.7. Definition of the calculation type: "Parameters" menu
Select the "Parameters" menu to define the type of excitation. The menu allows the user to:

• To perform a frequency-wise calculation,
• To perform an incident angle-wise calculation,
• To set the software to inhomogeneous multilayer configuration,
• To apply a spatial windowing in the case of a transmission calculation.



Menu "Paramétrer"

2.7.1. Frequency mode or angle mode

In a frequency-wise calculation, it is possible to select a diffuse field excitation (integration of plane 
waves) or  a plane  wave excitation.  The frequency-wise calculation  can be performed in linear  or 
logarithmic narrow bands, in octave bands or third octave bands. For diffuse field conditions, it is  
possible to compute two indicators, depending on the multilayer configuration:

• The αW et DLα indicators (if the lower layer is a rigid wall), 
• The Rw et DLr indicators (if the lower layer is a transmission medium). 

For an incident angle wise calculation, the only input is the frequency for the computation.

 

Calculation options : frequency-wise, incident angle-wise



2.7.2. Inhomogeneous multilayer

The inhomogeneous multilayer allows the user to create a multilayer material composed of various 
zones. Each zone is described by a MAINE 3A model file..

Inhomogeneous multilayer configuration

Note:  the  parameters  used  for  calculation  are  those contained  in  the  model  file  associated  to  the 
inhomogeneous multilayer (calculation parameters contained in the files of the zones are not taken into 
account).

Each zone can be weighted by a % of the surface. The sum of all weigths must be 100.

Because the weighting is a post-processing, it is possible to modify the weights of the zones without 
having to  redo the  whole  calculations.  This  can  be  achieved  by checking  the  "partial  calculation 
(weighting)" box. Whenever this is done, the parameters are frozen and the previous results are deleted 
by default. Therefore it is preferable, when using the "partial calculation" option, to check it before 
running the first calculation, otherwise it will be needed to re-launch the calculation.

2.7.3. Ponderation file 

It is possible to add a weighting to a theoretical transmission loss calculation so as to account for 
experimental  setup  conditions  (panel  dimensions)  [15,16].  The  spatial  window  depends  on  the 
frequency and incidence angle.  It  is taken into account  during the integration of plane waves that 
compose  the  diffuse  field.  This  operation  requires  to  pre-compute  some  coefficients  (see  the 
Tools/Spatial windowing definition menu), then recall these coefficients.

Whenever the Inhomogeneous multilayer option is activated, the same spatial weighting is applied to 
each zone. The spatial weighting is defined along with the multizone model (see previous chapter).

The spatial  window weighting must be adequate to the entire surface of the sample (see  Scientific 
references).



Caculation options: ponderation file selection.
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Mesure de l'indice d'affaiblissement 
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Comparing measurements to simulations: transmission loss of two finite dimensions samples.

2.8. Running the calculation: the "Launch" menu
Launch the calculation by selecting the calculation menu or the green arrow in the lower right corner.  



The calculation starts immediately, and the arrow becomes red: the graphical interface is then frozen, 
and the calculation cannot be interrupted. The calculation time can range from a few seconds to a few 
minutes, depending on the type of excitation and the number of frequency points.

Launch the calculation using the "compute" button or the arrow icon in the lower right corner. 

2.9.  Display and results management: the "Graph" menu 
Depending on the type of calculation, various results can be accessed in the "Graph" menu: absorption 
coefficient,  reflection  coefficient,  impedance,  transmission  loss,  diffuse  field  absorption,  transfer 
impedance. Results that are not available with the selected type of calculation will appear in grey.

Whenever the bottom layer is a transmission medium and non-diffuse field excitation is applied, some 
values will be defined on each side of the layered medium. To distinguish between them the suffix "_I" 
is used for the incident side and the suffix "_T" is used for the transmission side.

The "Graph" menu

By selecting a result, a graphics window opens to display the corresponding curve. Several graphics 
windows can be opened at the same time. If the calculations of standard indicators were requested, the 
values appear in the chart window of the losses by transmission. The text can be moved using the right  
button of the mouse.



Check the Graphics section for more details.

2.9.1. Special case: transfer impedance

This option allows to process the case of an impedance calculation which takes into account the 
displacement of the lower layer [17].

2.10. Additional functions: the "Tools" menu
The "Tools" menu gives access to additional functions.

The "Tools" menu

2.10.1. The "Spatial windowing definition » menu

It  is  possible  to  account  for  experimental  conditions  (finite  sample  dimensions)  by  weighting  a 
theoretical calculation [15,16]. The spatial window depends on the frequency and incidence angle. By 
clicking the "Start" button, the weighting coefficients are calculated (the operation can take some time) 
and stored into .bin file. This file can be used for any later calculation through the Parameters/Spatial 
windowing menu.

The minimum and maximum frequencies are fixed by the user. It is required that they overlap the 
frequency range used for simulations. The incidence angles must cover the 0° - 90° range. The number 
of frequency points and angle points are given as an indication for a correct use of the tool. During a 
transmission loss calculation with spatial window weighting, the values of the weighting coefficients 
are interpolated. Reducing the number of angles and/or frequencies reduces the file calculation time, 
but might alter the quality of the final result.



Spatial windowing parameters

2.10.2. The "Fibrous compression" menu

This feature allows to simulate the effect of compression on a fibrous material’s acoustic parameters, 
depending on the average diameter of the fibers (see scientific references). The compression is applied 
depending on the material’s thickness [5, 6].

1. In the left frame, select the material to be compressed among the database,
2. Input the average diameter of the fibers,
3. Select the compression ratio using the cursor,
4. Save the new material into a database.

Tools for fibrous materials compression



2.10.3. The "Database cleanup" menu

This menu allows the user to select a database to delete materials.

2.10.4. Database import/export : the "Database" menu

This menu allows the user to import or export a database into a file that can be opened by most table 
editors. It is possible to select the desired decimal separator.

2.10.5.  Language selection: the "Language" menu

This menu allows the user to modify the language used by MAINE 3A. The only languages available 
are French and English. Please contact us if you wish to volunteer for additional translations.

2.11. Graphics
All graphics windows share the same structure. They feature two menus: "Curves" and "Format".

2.11.1. The "Curves" menu

The "Curves" menu

The "Curves" menu gives access to various functionalities:

• [Save as] Saves the values into a .txt extension text file, compatible with most table editors. A 



pop-up window allows the user to select the results that will be stored into the file.

The two windows allowing the selection of the curves.

• [Export] Exports the graph in .eps extension Postscript format,
• [Reference] allows the display of up to 4 reference curves. The data for the reference curves 

must be stored in a file either using either the same formatting as MAINE 3A exports (text file 
with three lines of comments, frequencies in the first column, data in the next columns) or a 
more flexible format (indefinite number of lines starting with #, then frequencies in the first 
column and data in the next columns).

Whenever a file is selected a dialog box displays a preview of the file and allows the user to  
select the column's number containing the desired data.

The software automatically detects the decimal separator (dot or comma). The curve is then 
traced with a color, and a label with the filename is displayed. It is possible to move the label 
using the mouse right-click, or delete the label by double right-clicking it.



Reference file preview window



Reference curve example

2.11.2. The "Format" menu

The "Format" menu

The "Format" menu allows the user to:

• autoscale (full scale option) or manually scale (scale option) the graph and grid
• select the main curve’s type (curve option). The reference curves are not configurable.

It is also possible to add:

• titles,
• comments,
• two vertical marks and two horizontal marks. Their coordinates display in the graph header.

All these elements can be moved or deleted by using the mouse. See the summary table below.



Command Effect

Right-click Move object

Double right-click Delete object

Ctrl + click Zoom

Double click Full scale

Curves manipulation

By placing the mouse pointer over the graphic zone, its coordinates display in the upper band: this 
feature allows for an easy check oft he curve’s values. Exact values are available by saving the curve 
and editing the corresponding .txt file.

Curve example

The curves are automatically refreshed when a new calculation is performed.
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